excalibur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorg Heymans ...@domek.be>
Subject Re: releasing excalibur, partially this time - UPDATE
Date Sat, 26 Aug 2006 19:07:52 GMT
On 26 Aug 2006, at 15:45, Leo Simons wrote:

> Hmm. IIRC the old maven build was set for 1.4 so we haven't done this
> for a while. But I'm not sure.

Using JDK 1.3.1 compilation fails with

/Users/jheymans/src/excalibur-trunk/containerkit/logkit/src/java/org/ 
apache/log/output/jms/JMSTopicTarget.java:[19,-1] cannot access  
javax.jms.Message
bad class file: /Users/jheymans/src/excalibur-trunk/tempRepo/org/ 
apache/geronimo/specs/geronimo-jms_1.1_spec/1.0.1/geronimo- 
jms_1.1_spec-1.0.1.jar(javax/jms/Message.class)
class file has wrong version 48.0, should be 47.0

So i grabbed the sun sources of the jms spec myself and compiled them  
using 1.3, but then it failed on javax.mail with the same error.
Using 1.4.2 everything compiles fine, how to proceed now with this ?

>
> Gump provides some nice insights into these kinds of issues - it  
> used to
> run with both a 1.4 and a 1.5 JDK, and there were always significantly
> different results.
>

Interesting, you mean unforeseen things can happen when compiling  
source using jdk 1.5 with a 1.3 target and then running it on a 1.3  
jdk?Anything specific you've experienced ? (keen to learn something  
new here)


Jorg


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@excalibur.apache.org
For additional commands, e-mail: dev-help@excalibur.apache.org


Mime
View raw message