excalibur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leo Simons <m...@leosimons.com>
Subject Re: Which JVM compatibility do we want to force for our stuff?
Date Sat, 15 Jan 2005 14:11:53 GMT
On 14-01-2005 17:55, "Berin Loritsch" <bloritsch@d-haven.org> wrote:
> I am going to set the proper information for the maven properties to
> ensure that when someone compiles the code it will
> produce class files for the proper version compatibility.  I want to
> release Fortress 1.2 ASAP, esp. since I need it for a
> demo I am finishing for the end of next week.

I think just about all of Excalibur is 1.3-compatible. IIRC we set that as
the target for excalibur before it moved to a separate TLP, and we set 1.2
as the target for framework and logkit. With of course the note that you
can't compile framework and logkit without 1.4 as they reference the jdk
logging stuff.

It would sure be nice for some people if you could build some official
distros. Note you'll probably want a release of all of fortress its deps as
well since many things changed based on improvements to logkit (IIRC). I.e.
It probably needs to be a full stack release. Fortunately, the release
process should be just about completely automated now.

I guess beta releases would be ideal, but I guess you probably don't have
time for that.

Cheers,

- Leo



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@excalibur.apache.org
For additional commands, e-mail: dev-help@excalibur.apache.org


Mime
View raw message