excalibur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@d-haven.org>
Subject Re: Fortress startup error
Date Thu, 29 Jul 2004 13:23:25 GMT
Leif Mortenson wrote:

> This has only happened once, but today when starting up Fortress, I got the
> following error printed out to my console:
> 
> java.util.NoSuchElementException
> at java.util.LinkedList.getLast(LinkedList.java:118)
> at org.d_haven.event.impl.DefaultPipe.retrieveElements(DefaultPipe.java:140)
> at org.d_haven.event.impl.DefaultPipe.doDequeueAll(DefaultPipe.java:117)
> at org.d_haven.event.impl.AbstractPipe.dequeueAll(AbstractPipe.java:193)
> at
> org.d_haven.event.command.EventPipelineRunner.run(EventPipelineRunner.java:93)
> at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(Unknown
> Source)
> at java.lang.Thread.run(Thread.java:534)
> 
> Fortress continued to start up normally as if there had not been a
> problem. Looks
> like a bug in the D-Haven code.

Ok, I will look into this.  This is the one time I don't really like
Runtime Exceptions.

-- 

"Programming today is a race between software engineers striving to
build bigger and better idiot-proof programs, and the Universe trying to
produce bigger and better idiots. So far, the Universe is winning."
                - Rich Cook

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@excalibur.apache.org
For additional commands, e-mail: dev-help@excalibur.apache.org
Apache Excalibur Project -- URL: http://excalibur.apache.org/


Mime
View raw message