etch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Marsh <>
Subject Compiling Etch: C Binding Runtime
Date Mon, 15 Aug 2011 19:28:27 GMT

I am working with Scott Comer at Spawn Labs who suggested I write to this
list. I am currently trying to compile the C bindings for Etch and
experiencing some difficulties.

The compilation platform is Linux, and I am using the latest SVN (revision
1157946). The compilation succeeds until reaching the binding-c directory.
It appears unable to generate the makefiles, and ends with this error:.

Buildfile: /home/tmarsh/work/svn/etch/trunk/binding-c/runtime/build.xml
  [taskdef] Could not load definitions from resource cloverlib.xml. It could
not be found.
  [taskdef] Could not load definitions from resource
org/apache/ant/dotnet/antlib.xml. It could not be found.


     [echo] =====================================
     [echo] Build     : etch-c-runtime
     [echo] Build-Type: stable
     [echo] =====================================






    [cmake] Building cmake output
    [cmake] gmake: *** No targets specified and no makefile found.  Stop.

/usr/bin/gmake returned error code 2

Total time: 1 second

I am not entirely familiar with Ant and CMake, but it is clear that no
Makefile is generated. Investigating the CMakeLists.txt shows hard-coded
locations for apr, apr-iconv, etc., with some errors so I believe this file
may be out of date.

It is possible to fix the CMakeLists.txt by hand and run cmake/make to get
compilation to a certain point (object files, but I have not successfully
linked the test executables yet). Before I proceed further with debugging
the compilation scripts, I would like to ensure I am not making any obvious
errors. Am I missing something?

Thanks, and best regards,


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message