esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Imtiaz Ahmed H E" <>
Subject Re: [REL 1.1] Problems with JDBC-based Search
Date Thu, 09 Sep 2010 06:27:49 GMT
It works for me for the 'tags' 1.1 version with Derby jdbc.

But there's a nice new bug apparently, where the search results don't show 
the message, for example, searching for 'abra' in

abra abra
public 9 minutes ago via web

results in

public 10 minutes ago  web


----- Original Message ----- 
From: "Richard Hirsch" <>
To: <>
Sent: Thursday, September 09, 2010 11:02 AM
Subject: Re: [REL 1.1] Problems with JDBC-based Search

On Thu, Sep 9, 2010 at 5:59 AM, Imtiaz Ahmed H E <> 
> Didn't actually try running the tagged version (1.1)...
> Looked at the compass config files.
> Did you use compass.jdbc.cfg.xml (for Derby) or compass.mysql.jdbc.cfg.xml
> (for MySQL) ?

used both - I tried to localize the problem with the derby-based file
> Obviously, you did this - for the MySQL version provided the appropriate
> driverManager element in the config xml file ? Right now the file has the
> element commented out and without any real I had created it.

I added the values for the stax environment and deployed it there but
it didn't work
> The jdbc Derby version should work, it *had* worked for me when I renamed 
> it
> to compass.cfg.xml, when I fixed it earlier...

it worked for me as well - what is strange is that the derby-based
index db isn't being created when the app starts and after adding a
word and then searching, nothing is found.  I thought my UI changes
might be the reason but when I changed to file-based compass indexes
it worked.
> Let me know and let's see if I need to try out the tagged version on my
> system...
> As Ethan suggested once, enter a new message and look for a word in the
> message...
> Imtiaz
> ----- Original Message ----- From: "Richard Hirsch" 
> <>
> To: <>
> Sent: Thursday, September 09, 2010 1:50 AM
> Subject: [REL 1.1] Problems with JDBC-based Search
>> I've been testing the tagged version and I'm having some problems with
>> the jdbc-based search. I tried it on stax and it didn't work and then
>> I tried it locally and it didn't work. I switched back to file-based
>> indexes and it worked again. Maybe someone else can have a look to see
>> if the tagged version has some error.
>> What is strange is that it worked at one time. I have no idea what
>> changed.
>> Thanks
>> D.

View raw message