esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Hirsch <>
Subject Re: Something not quite right when testing RC
Date Sat, 20 Feb 2010 19:18:38 GMT
What is strange is that Ethan tests the compass search via tags in the
API2Test.scala. It is the "with tag restrictions" test. How come that
works then?

On Sat, Feb 20, 2010 at 8:15 PM, Richard Hirsch <> wrote:
> @sig: please change the default.props file to the following line and
> see if ESME is still broken.
> compass_config_file=/props/compass.filesystem.cfg.xmll
> This means that API is broken? I just depended on the scala tests and
> "mvn jetty:run".
> D.
> On Sat, Feb 20, 2010 at 7:46 PM, Sig Rinde <> wrote:
>> Ethan,
>> via the API, doing all from there - using the web interface only to
>> check if all's ok (and to create and copy the api_test token when
>> beginning a new instance).
>> BTW, reverted to old build, deleted the DB folder before starting up.
>> It did it's job fetching much new files and started without a glitch.
>> Then started a new Thingamy instance using exactly same procedure,
>> copy of same thingamy file etc. All's well there.
>> Just for the note; the missing compass folder is /server/compass-index
>> when I compare the old and new ESME build, the new one have no such
>> folder.
>> S
>> On 20 February 2010 19:41, Ethan Jewett <> wrote:
>>> Hi Sig,
>>> Just to clarify, this is from the web interface or via the API?
>>> Anyway, I fired up the server, logged in to the web interface, and
>>> tried to do a search. Got a big ugly error. So I'll retract my +1 on
>>> this release - something is wrong with Compass search when it is
>>> running in non-test mode. Search seems to be working when it is
>>> running in test mode. I'll take a look at the config now and see if I
>>> can see why.
>>> Ethan
>>> On Sat, Feb 20, 2010 at 12:27 PM, Sig Rinde <> wrote:
>>>> Started up a new and fresh RC on my OS X box, did the usual token stuff.
>>>> Fired up a new Thingamy instance and connected, all hunky dory.
>>>> Logged on as two different users from two different boxes - all fine,
>>>> discussion worked all visible etc.
>>>> Then logout and log on as any user - empty ESME interface. No Public
>>>> timeline. Then new message and, as before, visible. Until logout and
>>>> log in again, empty.
>>>> All messages are visible in the ESME interface, but after new login
>>>> all prior messages are not downloaded. All new messages, own and from
>>>> other connections, are downloaded.
>>>> Could this be related to the Compass (search function added earlier)?
>>>> There's no more "compass-index" folder in db folder I have noticed.
>>>> And, no, no changes at all on our side.
>>>> S

View raw message