esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sig Rinde <...@rinde.com>
Subject Re: [VOTE] Approve the release of apache-esme-incubating-1.0 - (Yes Again :->)
Date Mon, 22 Feb 2010 07:10:33 GMT
Ethan,

you were right! So much easier to find errors when one knows where to look :)

A single tailing space character after the rol.api_test line, sneaky
little invisible character...

My fault, used copy past using textmate. Next time vi only...

Sorry for confusion.

S

On 22 February 2010 00:35, Ethan Jewett <esjewett@gmail.com> wrote:
> Hi Sig,
>
> I'm guessing that there is something wrong with your default.props
> file. I say this because pool creation does not require the
> integration-admin role and is working. User creation does require the
> integration-admin role and is not working. This indicates to me that
> either the api_test user is not set up as an integration-admin or the
> token you are using for your API calls from Thingamy belongs to a
> different user.
>
> If you could also send the contents of the default.props file in your
> server/src/main/resources/props and server/target/classes/props/
> folders, that would be helpful. If the two are different, then you may
> need to do a "mvn clean install" in order to pick up the changes
> you've made.
>
> If *that* doesn't work, can you tell me the exact call you are making
> to "api2/users" and then what the response code is?
>
> Ethan
>
> On Sun, Feb 21, 2010 at 3:14 PM, Sig Rinde <sig@rinde.com> wrote:
>> Ethan,
>>
>> and sorry for me confusing :)
>>
>> The test_api line was/is in the default.props file, same as always.
>>
>> WIthout that I guess I could not have connected which it did, creating
>> a pool as always. So far all as normal.
>>
>> It's when I want to add the other users and asking for a token in
>> return nothing happens. Our side recieves nothing and the user I'm
>> trying to add does not show as a user in ESME web interface.
>>
>> S
>>
>> On 21 February 2010 22:04, Ethan Jewett <esjewett@gmail.com> wrote:
>>> Hi Sig,
>>>
>>> Yes, sorry for the confusion, you definitely need to add the api_test
>>> line to default.props (you can just copy from test.default.props)
>>> because you are using ESME in an integration scenario and making use
>>> of the API methods that require the integration-admin role.
>>>
>>> Once you do this and create your api_test user (and token), you should
>>> be able to go ahead. As far as I know, the only change since the last
>>> release candidate is the change I made to default.props.
>>>
>>> Please let us know if you continue to have problems after doing this.
>>>
>>> Please also note, that there is no particular reason that you need to
>>> have this user be called "api_test", but my understanding is that that
>>> is the username you are using for Thingamy/ESME integration. If it is
>>> actually a different user, please adjust the contexts of
>>> test.default.props accordingly.
>>>
>>> Thanks,
>>> Ethan
>>>
>>> On Sun, Feb 21, 2010 at 1:36 PM, Sig Rinde <sig@rinde.com> wrote:
>>>> Ethan, used the second option and it started up fine:
>>>>
>>>> Now I suddenly cannot create tokens for users in Thingamy any more... hmm.
>>>>
>>>> Added the api_test line to default.props, connecting to ESME using
>>>> token worked, it created a pool as planned.
>>>>
>>>> Nothing to be seen in terminal stream from ESME server, on my side
>>>> it's waiting for ESME token.
>>>>
>>>> What are the changes since the last that could affect my side?
>>>>
>>>> Same copy of same thingamy template, all same here.
>>>>
>>>> Sig
>>>>
>>>> On 21 February 2010 20:04, Ethan Jewett <esjewett@gmail.com> wrote:
>>>>> Ha! Ok, let's see if I can figure out how to do this :-)
>>>>>
>>>>> In order to check out this tag into a folder called "esme_test", you
>>>>> need to run the command: "svn checkout
>>>>> http://svn.apache.org/repos/asf/incubator/esme/tags/apache-esme-1.0-incubating
>>>>> esme_test"
>>>>>
>>>>> If you are not interested in a source-controlled copy of ESME, you can
>>>>> just use the command: "svn export
>>>>> http://svn.apache.org/repos/asf/incubator/esme/tags/apache-esme-1.0-incubating
>>>>> esme_test"
>>>>>
>>>>> Ethan
>>>>>
>>>>> On Sun, Feb 21, 2010 at 12:30 PM, Sig Rinde <sig@rinde.com> wrote:
>>>>>> Ethan,
>>>>>>
>>>>>> remember I'm a geek-in-training!
>>>>>>
>>>>>>> Just the usual SVN process, but grab the tag instead of the trunk
:-)
>>>>>>
>>>>>> Eh?
>>>>>>
>>>>>> Please, something expanded and specific! :-)
>>>>>>
>>>>>> Sig
>>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
View raw message