esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Hirsch <hirsch.d...@gmail.com>
Subject Error for API2 tests
Date Mon, 09 Nov 2009 08:58:57 GMT
Just tried to use the new tests for the API and received the following error.

rc\test\resources
[INFO] [compiler:testCompile {execution: default-testCompile}]
[INFO] Nothing to compile - all classes are up to date
[INFO] [scala:testCompile {execution: default}]
[INFO] suggestion: remove the scalaVersion from pom.xml
[ERROR] D:\temp\committer_esme\trunk\server\src\test\scala
[ERROR] D:\temp\committer_esme\trunk\server\src\test\scala\..\scala
[INFO] Compiling 5 source files to D:\temp\committer_esme\trunk\server\target\te
st-classes
[WARNING] D:\temp\committer_esme\trunk\server\src\test\scala\org\apache\esme\lib
\MsgParseTest.scala:302: error: JettyTestServer is already defined as object Jet
tyTestServer
[WARNING] object JettyTestServer {
[WARNING]        ^
[WARNING] one error found

I tried to change "JettyTestServer " to "JettyTestServerAPI" and I get
different errors. There appears to be some conflict between the
MsgParseTest.scala tests and those in Api2Test.scala.

I'll check in the API2.scala file but could you check and see what is
the problem with the tests.

Thanks.

D.

Mime
View raw message