esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ethan Jewett <esjew...@gmail.com>
Subject Re: Not a lot of ESME output from me today
Date Fri, 13 Nov 2009 14:50:35 GMT
Hi,

It looks like these tests got checked in even though they don't run as
yet. Can they be commented out until they are operational? Currently
they are causing the full test run to fail, which is not the end of
the world but is something we should probably avoid.

Ethan

On Tue, Nov 10, 2009 at 7:04 PM, David Pollak
<feeder.of.the.bears@gmail.com> wrote:
> Folks,
>
> I started writing some ESME tests and got very cranky with Lift's TestKit
> (what kind of fool wrote those APIs anyway... oh, look, here's a mirror and
> I'm looking at the fool).
>
> I spent a couple of hours cleaning up the Lift TestKit APIs so that tests
> will look like:
>
>    "Login" in {
>      for{
>        login <- post("/api/login", "token" -> token) !@ "Failed to log in"
> if (testSuccess(login))
>        status <- login.get("/api/status") !@ "Failed to get status" if
> (testSuccess(status))
>      } {
>        (status.xml \ "user" \ "@id").text must_== theUser.id.toString
>      }
>    }
>
> Once the Lift changes get approved and propagated, I'll post up the new API
> test code.
>
> I plan to spend more time in ESME-land on Thursday and will get some of the
> user edit and OpenID stuff finished.
>
> Thanks,
>
> David
>
> PS -- What's the ETA for the new templates?
>
>
> --
> Lift, the simply functional web framework http://liftweb.net
> Beginning Scala http://www.apress.com/book/view/1430219890
> Follow me: http://twitter.com/dpp
> Surf the harmonics
>

Mime
View raw message