esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anne Kathrine Petter√łe <>
Subject Re: [Lift] JSON handler doesn't respond
Date Tue, 01 Sep 2009 05:42:35 GMT
I only use Firefox as a browser, and have had this error several times.
So maybe it is the browser making a difference?


On 01 Sep, 2009, at 06:51 , Vassil Dichev wrote:

> I built Lift locally and put dumps in LiftSession's cleanupUnseenFuncs
> and updateFuncByOwner. So far I cannot reproduce the problem.
>>>    <snapshot>
>>>      <buildNumber>1724</buildNumber>
>>>    </snapshot>
>>>    <lastUpdated>20090828152733</lastUpdated>
>>> Do I have the correct updated jar?
>> I have no idea.
> Since you've mentioned in the past that you're using hudson for
> building the lift jars before they're uploaded to the public maven
> repo, I was hoping that one can associate the build number or date
> with the specific commit.
>> Can you specify the exact steps to reproduce the problem?  I have  
>> really,
>> really tried to make it happen and can't. :-(
> I'm using Firefox, on different versions of Linux. I have three users
> (e.g. a follows b, b follows c) and I open up the ESME main page in a
> separate browser for each user. I post a message for each to make sure
> it works. I leave the browsers open and after a while I check again
> whether I can send a message with all users. Usually half an hour is
> enough for 2-3 of the users to block. The problem can always be
> reproduced on the Stax instance, too, by just leaving a session open-
> Dick can confirm that it regularly happens to him, too. Maybe he can
> add some details on how he reproduces it.
> Let's see if the fix works this time. If not, the only difference I
> can think of is the browser- you could be using Chrome or Safari. I've
> tried reproducing with Chrome in the past once or twice and couldn't.
> Vassil

View raw message