esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darren Hague <dha...@fortybeans.com>
Subject RE: AW: Maven Build is broken
Date Wed, 04 Mar 2009 09:39:33 GMT
The Maven dependencies are controlled from the pom.xml file - however, icu4j is not listed
there, so it must be a dependency-of-a-dependency. The problem is really with the Maven repository
- jars for previous versions should not be removed. The solution is a little tricky - we need
to find out the dependency chain from icu4j to one of the items in our pom.xml (perhaps running
"mvn -e compile" might help) - once we find out which of our dependencies is involved, we
may be able to up the version number on our side to try and solve the issue.

I'm at work right now, so I can't try this - I'll have a look this evening (8 hours' time)
if no-one else solves it before then.

Cheers,
darren

>I just looked at the modification date for jar in question. It isn't a recent 
>change. So, obviously the change is somewhere else.
> 
>D. 
>
>________________________________
>
>Von: Hirsch, Richard
>Gesendet: Mi 04.03.2009 08:56
>An: esme-dev@incubator.apache.org
>Betreff: Maven Build is broken
>
>
>
>As Daniel pointed out last night, the maven build is currently broken.
>
>I have no idea if the problem is scala- or maven-based.
>
>http://repo1.maven.org/maven2/com/ibm/icu/icu4j/3.4.1/icu4j-3.4.1.jar can not 
>found, because there has been a version change from 3.4.1 to 3.4.4/
>
>Does anyone know how to solve this problem?
>
>
>
>D.
>
>
>
>
>
>
>



-- 
darren.hague@fortybeans.com

Mime
View raw message