esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Pollak" <feeder.of.the.be...@gmail.com>
Subject The Dreaded OpenID issue
Date Fri, 19 Dec 2008 13:04:42 GMT
Folks,
When I was moving the ESME server to a new machine (same database, byte-copy
of my Tomcat instance), I started getting:

org.openid4java.message.MessageException: Invalid set of parameters
for the requested message type
	org.openid4java.message.AuthSuccess.createAuthSuccess(AuthSuccess.java:116)
	org.openid4java.consumer.ConsumerManager.verify(ConsumerManager.java:1110)
	net.liftweb.openid.OpenIDConsumer$class.verifyResponse(OpenId.scala:284)
	us.esme.model.ESMEOpenIDConsumer.verifyResponse(User.scala:176)
	net.liftweb.openid.OpenIdVendor$$anonfun$dispatchPf$1$$anonfun$apply$8$$anonfun$apply$9.apply(OpenId.scala:142)
	net.liftweb.openid.OpenIdVendor$$anonfun$dispatchPf$1$$anonfun$apply$8$$anonfun$apply$9.apply(OpenId.scala:140)
	net.liftweb.util.Full.flatMap(Can.scala:266)

Whenever I tried log on using OpenID.

I know Daniel was experiencing this issue behind the firewall, but I'm
seeing it out on the open Internet.

Anybody got a clue as to what is going on and how to fix it?

Thanks,

David

PS -- Is our Assembla account still active because the live ESME code dates
back to Assembla days and I have to use that version rather than a new
version because there's a nasty bug in Scala 2.7.2 (it'll be fixed very soon
now) that causes memory leaks with Actors.


-- 
Lift, the simply functional web framework http://liftweb.net
Collaborative Task Management http://much4.us
Follow me: http://twitter.com/dpp
Git some: http://github.com/dpp

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message