empire-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Venditti <benjamin.vendi...@arcor.de>
Subject Re: [VOTE] Release Apache Empire-db 2.0.6-incubating (rc1)
Date Fri, 09 Apr 2010 22:55:52 GMT
Hi there,

just hat a look at the 2.0.6-incubating release.

I successfully tested:
	examples-advanced
	examples-basic
	examples-cxf
	examples-spring

I got an error while testing the CodeGenApp directly. The error will 
only occur if "nestTables" or "nestViews" is enabled. I think the 
problem is, that we never set the template folder property of the config 
object to a default value. Here is a snippet of the error ...

	Writing 
C:\Users\Hermine7\Workspaces\workspace-emp\empire-db-trunk\empire-db-codegen\target\generated\dbsample\org\apache\empire\db\samples\dbsample\SampleDB.java

  at 
org.apache.empire.db.codegen.CodeGenWriter.writeFile(CodeGenWriter.java:300) 

	ERROR [2010/04/10 00:31]: ResourceManager : unable to find resource 
'$templateFolder/Table.vm' in any resource loader.  at 
org.apache.velocity.runtime.log.CommonsLogLogChute.log(CommonsLogLogChute.java:96) 

	ERROR [2010/04/10 00:31]: #parse(): cannot find template 
'$templateFolder/Table.vm', called at templates/Database.vm[line 75, 
column 25]  at 
org.apache.velocity.runtime.log.CommonsLogLogChute.log(CommonsLogLogChute.java:96) 

	ERROR [2010/04/10 00:31]: Unable to find resource 
'$templateFolder/Table.vm'  at 
org.apache.empire.db.codegen.CodeGenWriter.writeFile(CodeGenWriter.java:307) 

	org.apache.velocity.exception.ResourceNotFoundException: Unable to find 
resource '$templateFolder/Table.vm'
		at 
org.apache.velocity.runtime.resource.ResourceManagerImpl.loadResource(ResourceManagerImpl.java:483)
		at 
org.apache.velocity.runtime.resource.ResourceManagerImpl.getResource(ResourceManagerImpl.java:354)
	....

Unfortunately i was not able to test the web-examples as i alyways got 
an error on starting them. I'm not sure if my tomcat installation or 
configuration is messed up, and i'd be happy if someone could help me 
with that. Here is also a snippet of the error:

	WARNUNG: [SetPropertiesRule]{Server/Service/Engine/Host/Context} 
Setting property 'source' to 
'org.eclipse.jst.j2ee.server:empire-db-example-struts2' did not find a 
matching property.
	...
	SCHWERWIEGEND: Exception starting filter struts2
	java.lang.ClassNotFoundException: 
org.apache.empire.struts2.web.EmpireFilterDispatcher
		at 
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1387)
		at 
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1233)
		at 
org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:249)


best regards benjamin

Mime
View raw message