empire-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Döbele (JIRA) <empire-db-...@incubator.apache.org>
Subject [jira] [Commented] (EMPIREDB-210) Wrong Java Type in Records for BLOB Columns
Date Thu, 28 Aug 2014 09:29:58 GMT

    [ https://issues.apache.org/jira/browse/EMPIREDB-210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14113596#comment-14113596
] 

Rainer Döbele commented on EMPIREDB-210:
----------------------------------------

Hi Jan,

again, well done.
Thanks for this one too.

Rainer

> Wrong Java Type in Records for BLOB Columns
> -------------------------------------------
>
>                 Key: EMPIREDB-210
>                 URL: https://issues.apache.org/jira/browse/EMPIREDB-210
>             Project: Empire-DB
>          Issue Type: Bug
>          Components: CodeGenerator
>    Affects Versions: empire-db-2.4.3
>            Reporter: jan
>            Priority: Minor
>             Fix For: empire-db-2.4.4
>
>         Attachments: Record.vm.patch
>
>
> When using the empire-db-codegen project to reverse engineer an existing database the
data type BLOB is broken. For example the getter in the record for column BLOB_VALUE (Data
Type BLOB) is generated as:
> public [Ljava.lang.Byte; getBlobValue() {
> 	return ([Ljava.lang.Byte;)super.getValue(getTable().BLOB_VALUE);
> }
> "[Ljava.lang.Byte;" is clearly wrong.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message