empire-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jan (JIRA)" <empire-db-...@incubator.apache.org>
Subject [jira] [Updated] (EMPIREDB-125) Investigate and solve problem with the location of velocity templates on the code generator when integrated in own projects
Date Tue, 26 Aug 2014 09:31:58 GMT

     [ https://issues.apache.org/jira/browse/EMPIREDB-125?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

jan updated EMPIREDB-125:
-------------------------

    Attachment: EMPIREDB-125.patch

I think the problem is that Velocity likes to have the template in the root-folder of the
jar. 

To solve the issue for me I added /src/main/resources/templates to as 'resource' (in pom.xml)
and changed some lines in Database.vm and CodeGenWriter.java (see attached patch)

All tests are still working.

> Investigate and solve problem with the location of velocity templates on the code generator
when integrated in own projects
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: EMPIREDB-125
>                 URL: https://issues.apache.org/jira/browse/EMPIREDB-125
>             Project: Empire-DB
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: empire-db-2.3.0
>            Reporter: Rainer Döbele
>            Priority: Minor
>         Attachments: EMPIREDB-125.patch
>
>
> When the code generator is embedded in other projects, the velocity templates are not
loaded from the resources.
> Circumstances for this behavior must be investigated and potential problem should be
solved.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message