empire-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Döbele (JIRA) <empire-db-...@incubator.apache.org>
Subject [jira] [Resolved] (EMPIREDB-175) rename misleading method name that fasly suggests a redirect
Date Thu, 05 Sep 2013 08:52:51 GMT

     [ https://issues.apache.org/jira/browse/EMPIREDB-175?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Rainer Döbele resolved EMPIREDB-175.

       Resolution: Fixed
    Fix Version/s: empire-db-2.4.2

Method renamed to Page.navigateTo
> rename misleading method name that fasly suggests a redirect
> ------------------------------------------------------------
>                 Key: EMPIREDB-175
>                 URL: https://issues.apache.org/jira/browse/EMPIREDB-175
>             Project: Empire-DB
>          Issue Type: Improvement
>          Components: JSF2 Extensions
>    Affects Versions: empire-db-2.4.2
>            Reporter: Rainer Döbele
>            Assignee: Rainer Döbele
>            Priority: Minor
>             Fix For: empire-db-2.4.2
> The method redirectTo in page.java is misleading since it suggests that a redirect is
> Rather whether a forward or direct is performed depends on the outcome parameter.
> Hence to avoid confusion this method should be renamed to navigateTo.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message