empire-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Francis De Brabandere (Created) (JIRA)" <empire-db-...@incubator.apache.org>
Subject [jira] [Created] (EMPIREDB-122) Chinese characters being inserted as ??? on SqlServer (non-prepared statement)
Date Wed, 09 Nov 2011 19:45:52 GMT
Chinese characters being inserted as ??? on SqlServer (non-prepared statement)
------------------------------------------------------------------------------

                 Key: EMPIREDB-122
                 URL: https://issues.apache.org/jira/browse/EMPIREDB-122
             Project: Empire-DB
          Issue Type: Bug
          Components: Core
    Affects Versions: empire-db-2.2.0-incubating
            Reporter: Francis De Brabandere
            Priority: Critical
             Fix For: empire-db-2.2.1-incubating


Reported by Ben Ng

Hi Empire-DB team,

I am trying to insert a record with Chinese character from my JSP page.
The encoding is set to UTF-8 already and I am trying to insert the record by the code below
where "remarks" is a string contain Chinese characters.

DBRecord rec = new DBRecord();
rec.create(db.REQUESTS);
rec.setValue(db.REQUESTS.REMARKS, remarks);
rec.update(conn);

After inserting the record, the data of the field REMARKS become "???". 


I tried to use traditional method(PreparedStatement) to insert this record by using the same
db and connection. 
The data can be inserted correctly.
Is there any step I have missed in my code so it can support UTF-8? 


I really appreciate for what your team have done. Thanks a lot.

Thanks & Regards,
Ben

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message