empire-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Francis De Brabandere (JIRA)" <empire-db-...@incubator.apache.org>
Subject [jira] Commented: (EMPIREDB-35) make sure our jar's are osgi compatible
Date Tue, 30 Mar 2010 21:26:27 GMT

    [ https://issues.apache.org/jira/browse/EMPIREDB-35?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12851610#action_12851610
] 

Francis De Brabandere commented on EMPIREDB-35:
-----------------------------------------------

Just changed the parent pom to add osgi manifest info to all jars. I actually looked at how
apache wicket does this and I did not have to change the packaging to bundle for now. See
"Adding OSGi metadata to existing projects without changing the packaging type" at http://felix.apache.org/site/apache-felix-maven-bundle-plugin-bnd.html


Greg could you please test the produced jars and make sure they work in your project? Do you
actually need the bundle packaging? As that is more for real osgi based projects, we for now
only want to support osgi.

> make sure our jar's are osgi compatible
> ---------------------------------------
>
>                 Key: EMPIREDB-35
>                 URL: https://issues.apache.org/jira/browse/EMPIREDB-35
>             Project: Empire-DB
>          Issue Type: Task
>          Components: Core
>    Affects Versions: empire-db-2.0.5-incubating
>            Reporter: Francis De Brabandere
>            Assignee: Francis De Brabandere
>            Priority: Minor
>
> add the needed info in the pom.xml's (see wicket)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message