edgent-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject Re: Understanding the snapshot and release process
Date Fri, 16 Jun 2017 08:46:38 GMT
In case of a variable for the groupId the warning is the same except that it mentions groupId
instead of version :-(

Chris



Am 15.06.17, 23:18 schrieb "Dale LaBossiere" <dml.apache@gmail.com>:

    ugh.  There are ~160 lines of this every time you run a mvn cmd…  and I hadn’t noticed
the:
    
    [WARNING]
    [WARNING] It is highly recommended to fix these problems because they threaten the stability
of your build.
    [WARNING]
    [WARNING] For this reason, future Maven versions might no longer support building such
malformed projects.
    [WARNING]
    
    Sounds pretty ominous.
    
    Seems to me like people will quickly tire of / get annoyed by this.
    Might it be a lesser of evils to put the java17 in the groupId instead?
    
    — Dale 
    
    > On Jun 15, 2017, at 11:55 AM, Christofer Dutz <christofer.dutz@c-ware.de> wrote:
    > 
    > Unfortunately we have to live with that.
    > Using variables for the versions can cause problems. In our case I made sure they
don't. But we need that in order to create the java 8 and java 7 packages.
    > 
    > But Maven tends to be over careful.
    > 
    > Chris
    > 
    > 
    > 
    > Von meinem Samsung Galaxy Smartphone gesendet.
    > 
    > 
    > -------- Ursprüngliche Nachricht --------
    > Von: Dale LaBossiere <dml.apache@gmail.com>
    > Datum: 15.06.17 17:19 (GMT+01:00)
    > An: dev@edgent.apache.org
    > Betreff: Re: Understanding the snapshot and release process
    > 
    > I just pulled down the latest PR contents into a new clone.  I get a bunch of warnings
like the one below (but things work).
    > 
    > mvn clean install
    > [INFO] Scanning for projects...
    > [WARNING]
    > [WARNING] Some problems were encountered while building the effective model for org.apache.edgent.analytics:edgent-analytics-sensors:jar:1.2.0-SNAPSHOT
    > [WARNING] 'version' contains an expression but should be a constant. @ org.apache.edgent.analytics:edgent-analytics-sensors:${edgent.version},
/Users/dlaboss/git/incubator-edgen\
    > t-4/analytics/sensors/pom.xml, line 31, column 12
    > 
    > — Dale
    
    

Mime
View raw message