edgent-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dale LaBossiere <dml.apa...@gmail.com>
Subject Re: Trying register an application via the registerJar command
Date Thu, 30 Mar 2017 14:19:53 GMT
> On Mar 28, 2017, at 12:40 PM, Susan Cline <home4slc@pacbell.net> wrote:
> ...
> I have not gotten back to this since Dale posted this a long time ago, but I’d like
to get this working.  

I’ve reread all of this thread - whew :-).  I think you’re very close.  Your jar is OK.
The registerJar cmd worked.  The submit cmd worked (with your getBuilder() that returned a
fn that just created a top that printed the app name).

I’ll stick with the assertion in my last msg of 9/26 11:24.  I think all that's left to
fix is:

- change your TopologyBuilder.getBuilder() impl
  from
	(t, c) -> buildTopology(t, c)
  to
	(t, c) -> buildTopology( IotDevicePubSub.addIotDevice(t), c))
	Notice that’s exactly what IotProvider.registerTopology() does - how the IotDevice will
get created for and passed to your builder/top

- change your buildTopology(Topology t, JsonConfig c) to
	buildTopology(IotDevice iotDevice, JsonConfig c)  <== just a rename of the accept() in
your 9/16/1:17 mail

I’m going to add a JIRA and improve the doc in IotProvider to make this clear.
— Dale
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message