edgent-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dale LaBossiere (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (EDGENT-248) [console] no hover popup for source oplet
Date Thu, 22 Dec 2016 22:57:58 GMT

     [ https://issues.apache.org/jira/browse/EDGENT-248?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dale LaBossiere reopened EDGENT-248:
------------------------------------

Maybe that was it!  I just tried with a full-width window and everything worked - the source
oplet is about 1/2 across the page, under the "Topology Graph" title (chrome fwiw).  

Then narrowing the window so the oplet is about 1/4 of the way across, under the "View by"
tag, and the popup doesn't show up. The window is still >3/4 the width of my screen. Incrementally
widening the window then makes it so the popup shows up.

Reopening.  The console needs to be smart enough to place the hover where it can be displayed
/ is visible.  The user has no clue what's going on and the window size is more than reasonable
when the problem happens.

Hmm... I also just noticed that if one continues to narrow the window, eventually the graph
slides off the LHS of the screen, whereas the rest of the widgets stay on the left and the
right gets clipped, and the slider bar doesn't help make the graph visible again.

> [console] no hover popup for source oplet
> -----------------------------------------
>
>                 Key: EDGENT-248
>                 URL: https://issues.apache.org/jira/browse/EDGENT-248
>             Project: Edgent
>          Issue Type: Bug
>          Components: Console
>            Reporter: Dale LaBossiere
>            Assignee: Queenie Ma
>         Attachments: HoverPopupWorking.png
>
>
> This used to work... if you hover on a source oplet (of any type?) no popup is generated.
 Hovering on other oplets works fine.  (can demo with sample file connector - see scripts/connectors/file/README)




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message