edgent-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Susan L. Cline (JIRA)" <j...@apache.org>
Subject [jira] [Created] (EDGENT-315) The d3 images on the streaming-concepts.html page are not appearing
Date Wed, 30 Nov 2016 01:32:58 GMT
Susan L. Cline created EDGENT-315:
-------------------------------------

             Summary: The d3 images on the streaming-concepts.html page are not appearing
                 Key: EDGENT-315
                 URL: https://issues.apache.org/jira/browse/EDGENT-315
             Project: Edgent
          Issue Type: Bug
          Components: Web Site
            Reporter: Susan L. Cline
            Priority: Minor


When I was reading this page it was referring to colors and streams and I could not see any
images.  It turns out that this error is being thrown when browsing to the page and looking
at a javascript console:

Mixed Content: The page at 'https://edgent.apache.org/docs/streaming-concepts.html' was loaded
over HTTPS, but requested an insecure script 'http://d3js.org/d3.v3.min.js'. This request
has been blocked; the content must be served over HTTPS.

This seems to be due to attempting to fetch the d3 library at a non-https url.  There is this
post about this:

https://github.com/jsbin/jsbin/issues/2549

Also, I tried changing the url from 'http://d3js.org/d3.v3.min.js' in my local incubator-edgent-website
'streaming-concepts.html' to 'https://d3js.org/d3.v3.min.js' and it seems to work fine.  I.e,
the images appear.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message