edgent-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rui Shen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (EDGENT-310) KafkaStreamsTestManual.testSimple() fails with no local zk or kafka servers
Date Mon, 14 Nov 2016 02:11:58 GMT

    [ https://issues.apache.org/jira/browse/EDGENT-310?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15662541#comment-15662541

Rui Shen commented on EDGENT-310:

Yes, agree. The functionality of the connector works correctly, but the tests failed. As I
said before, our project will use edgent Tester to test our Kafka connectors so now my Kafka
connector unit tests all failed because our Kafka server is a remote one. I agree that this
might not be high priority since it is just a test failure, but I have to track this issue
because my test report is red now, :). So appreciate if you could fix it (if you are not that
one who is working on edgent Tester class, maybe you could reassign this defect to that person
- I do think this is a Tester class issue but nothing to the connector). Looking forward to
your feedback. Thanks. 

> KafkaStreamsTestManual.testSimple() fails with no local zk or kafka servers
> ---------------------------------------------------------------------------
>                 Key: EDGENT-310
>                 URL: https://issues.apache.org/jira/browse/EDGENT-310
>             Project: Edgent
>          Issue Type: Test
>          Components: Test
>    Affects Versions: Apache Edgent 1.0.0
>         Environment: kafka_2.11-
>            Reporter: Rui Shen
> I have set up a kafka on local and a remote machine following the quick start guide http://kafka.apache.org/quickstart.
And I pulled the latest code of the branch "release1.0.0". I tried to run KafkaStreamsTestManual.testSimple(),
but found it works with local kafka but fails with the remote kafka (the error shown as below
). I have tested my remote kafka with my local kafka console client and the SimpleSubscriberApp.java
so I am sure that it works. And I even tried to start local kafka consumer console client
during testSimple() is running, I can get the messages ('Hello' and 'Are you there?') from
the console. So I am suspecting that there is something wrong with Edgent Tester to handle
this test case. 
> ================================
> java.lang.AssertionError:  contents:[]
> 	at org.junit.Assert.fail(Assert.java:88)
> 	at org.junit.Assert.assertTrue(Assert.java:41)
> 	at org.apache.edgent.test.topology.TopologyAbstractTest.completeAndValidate(TopologyAbstractTest.java:98)
> 	at org.apache.edgent.test.connectors.common.ConnectorTestBase.completeAndValidate(ConnectorTestBase.java:104)
> 	at org.apache.edgent.test.connectors.common.ConnectorTestBase.completeAndValidate(ConnectorTestBase.java:93)
> 	at org.apache.edgent.test.connectors.kafka.KafkaStreamsTestManual.testSimple(KafkaStreamsTestManual.java:133)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> 	at java.lang.reflect.Method.invoke(Method.java:498)
> 	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
> 	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
> 	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
> 	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
> 	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:26)
> 	at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:271)
> 	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:70)
> 	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:50)
> 	at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238)
> 	at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:63)
> 	at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:236)
> 	at org.junit.runners.ParentRunner.access$000(ParentRunner.java:53)
> 	at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:229)
> 	at org.junit.runners.ParentRunner.run(ParentRunner.java:309)
> 	at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50)
> 	at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
> 	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:459)
> 	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:675)
> 	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:382)
> 	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:192)

This message was sent by Atlassian JIRA

View raw message