edgent-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Queenie Ma (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QUARKS-129) rename SimulatedTemperatureSensor to facilitate reuse
Date Thu, 07 Apr 2016 18:04:25 GMT

    [ https://issues.apache.org/jira/browse/QUARKS-129?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15230727#comment-15230727
] 

Queenie Ma commented on QUARKS-129:
-----------------------------------

+1 I plan to update recipe_value_out_of_range.md and recipe_different_processing_against_stream.md
to use this new sensor.

> rename SimulatedTemperatureSensor to facilitate reuse
> -----------------------------------------------------
>
>                 Key: QUARKS-129
>                 URL: https://issues.apache.org/jira/browse/QUARKS-129
>             Project: Quarks
>          Issue Type: Improvement
>          Components: Samples
>            Reporter: Dale LaBossiere
>            Priority: Minor
>              Labels: newbie
>
> There's nothing about temperature specific about quarks.samples.utils.sensor.SimulatedTemperatureSensor.
 In fact the same basic code is used for a gas-mileage sensor in recipe_different_processing_against_stream.md.
> Rename this facilitate more reuse.  
> Not sure of a good name.
> Maybe SimpleRandomDeltaSensor or such.  
> Consider updating that recipe to use it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message