eagle-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jayesh Senjaliya <jhsonl...@gmail.com>
Subject Re: Can't build Eagle 0.5
Date Fri, 03 Feb 2017 21:11:43 GMT
cant figure out what  error you are facing from these logs, please try to
follow the installation guide from docs.


On Thu, Feb 2, 2017 at 6:21 AM, Markovich <amrivkin@gmail.com> wrote:

> Hi Jayesh,
>
> I've updated nodejs.
> Now build looks like:
>
> =============== Building Web UI ===============
> Environment Check...
> Environment Check...Pass
> npm install...
> building...
>
> > ApacheEagleWebApp@ build /u01/opt/eagle/eagle-server/src/main/webapp/app
> > node build/index.js
>
> Generating resource tree...
> Grunt packaging...
>
> > ApacheEagleWebApp@ grunt /u01/opt/eagle/eagle-server/src/main/webapp/app
> > grunt
>
> Killed
>
>
> Any ideas?
>
>
> # node -v
> v6.9.1
> # npm -v
> 3.10.8
> # java -version
> openjdk version "1.8.0_101"
> OpenJDK Runtime Environment (build 1.8.0_101-b13)
> OpenJDK 64-Bit Server VM (build 25.101-b13, mixed mode)
> # scala -version
> Scala code runner version 2.11.8 -- Copyright 2002-2016, LAMP/EPFL
>
> Regards,
> Andrey
>
>
>
>
> 2017-02-02 0:46 GMT+03:00 Jayesh Senjaliya <jhsonline@gmail.com>:
>
>> Hi Markovich,
>>
>> looks like you have older nodejs  < 4 ?  can you try updating your nodejs
>> ?
>>
>> - Jayesh
>>
>> On Wed, Feb 1, 2017 at 5:36 AM, Markovich <amrivkin@gmail.com> wrote:
>>
>>> Hi Eagle users,
>>>
>>> Wanted to try this product, but failed to build version 0.5.
>>> Any ideas?
>>>
>>> =============== Building Web UI ===============
>>> Environment Check...
>>> Environment Check...Pass
>>> npm install...
>>> building...
>>>
>>> > ApacheEagleWebApp@ build /u01/opt/eagle/eagle-server/sr
>>> c/main/webapp/app
>>> > node build/index.js
>>>
>>> Generating resource tree...
>>>
>>> /u01/opt/eagle/eagle-server/src/main/webapp/app/node_modules
>>> /jsdom/lib/jsdom.js:3
>>> () => `jsdom 7.x onward only works on Node.js 4 or newer:
>>> https://github.com/t
>>>  ^
>>> SyntaxError: Unexpected token )
>>>     at Module._compile (module.js:439:25)
>>>     at Object.Module._extensions..js (module.js:474:10)
>>>     at Module.load (module.js:356:32)
>>>     at Function.Module._load (module.js:312:12)
>>>     at Module.require (module.js:364:17)
>>>     at require (module.js:380:17)
>>>     at /u01/opt/eagle/eagle-server/src/main/webapp/app/build/index.
>>> js:23:12
>>>     at Object.<anonymous> (/u01/opt/eagle/eagle-server/s
>>> rc/main/webapp/app/build/index.js:155:3)
>>>     at Module._compile (module.js:456:26)
>>>     at Object.Module._extensions..js (module.js:474:10)
>>>
>>> npm ERR! ApacheEagleWebApp@ build: `node build/index.js`
>>> npm ERR! Exit status 8
>>> npm ERR!
>>> npm ERR! Failed at the ApacheEagleWebApp@ build script.
>>> npm ERR! This is most likely a problem with the ApacheEagleWebApp
>>> package,
>>> npm ERR! not with npm itself.
>>> npm ERR! Tell the author that this fails on your system:
>>> npm ERR!     node build/index.js
>>> npm ERR! You can get their info via:
>>> npm ERR!     npm owner ls ApacheEagleWebApp
>>> npm ERR! There is likely additional logging output above.
>>> npm ERR! System Linux 3.8.13-118.8.1.el7uek.x86_64
>>> npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "run" "build"
>>> npm ERR! cwd /u01/opt/eagle/eagle-server/src/main/webapp/app
>>> npm ERR! node -v v0.10.30
>>> npm ERR! npm -v 1.4.21
>>> npm ERR! code ELIFECYCLE
>>> npm ERR!
>>> npm ERR! Additional logging details can be found in:
>>> npm ERR!     /u01/opt/eagle/eagle-server/sr
>>> c/main/webapp/app/npm-debug.log
>>> npm ERR! not ok code 0
>>> =============== Failed ===============
>>>
>>> Regards,
>>> Andrey
>>>
>>
>>
>

Mime
View raw message