eagle-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (EAGLE-968) using Email Notification Feature throws IncompatibleClassChangeError
Date Tue, 13 Jun 2017 13:18:00 GMT

    [ https://issues.apache.org/jira/browse/EAGLE-968?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16047878#comment-16047878
] 

ASF GitHub Bot commented on EAGLE-968:
--------------------------------------

Github user rushikesavareddy commented on a diff in the pull request:

    https://github.com/apache/eagle/pull/941#discussion_r121674184
  
    --- Diff: eagle-core/eagle-common/src/main/java/org/apache/eagle/common/mail/EagleMailClient.java
---
    @@ -53,16 +53,18 @@ public EagleMailClient(final Properties config) {
                 velocityEngine = new VelocityEngine();
                 velocityEngine.setProperty(RuntimeConstants.RESOURCE_LOADER, "classpath");
                 velocityEngine.setProperty("classpath.resource.loader.class", ClasspathResourceLoader.class.getName());
    +            velocityEngine.setProperty(RuntimeConstants.RUNTIME_LOG_LOGSYSTEM_CLASS,
Log4JLogChute.class.getName());
    --- End diff --
    
    @jhsenjaliya fixed


> using Email Notification Feature throws IncompatibleClassChangeError
> --------------------------------------------------------------------
>
>                 Key: EAGLE-968
>                 URL: https://issues.apache.org/jira/browse/EAGLE-968
>             Project: Eagle
>          Issue Type: Bug
>    Affects Versions: v0.5.0
>            Reporter: Jayesh
>            Assignee: Jayesh
>             Fix For: v0.6.0
>
>
> {code}
> 2017-03-19 20:42:56.369 o.a.e.a.e.p.e.AlertEmailGenerator Thread-46-alertPublishBolt-executor[17
17] [ERROR] Failed to send email to ****@gmail.com,****@gmail.com, due to:java.util.concurrent.ExecutionException:
java.lang.IncompatibleClassChangeError: Implementing class
> java.util.concurrent.ExecutionException: java.lang.IncompatibleClassChangeError: Implementing
class
> 	at java.util.concurrent.FutureTask.report(FutureTask.java:122) ~[?:1.8.0_102]
> 	at java.util.concurrent.FutureTask.get(FutureTask.java:206) ~[?:1.8.0_102]
> 	at org.apache.eagle.alert.engine.publisher.email.AlertEmailGenerator.sendAlertEmail(AlertEmailGenerator.java:89)
[stormjar.jar:?]
> 	at org.apache.eagle.alert.engine.publisher.email.AlertEmailGenerator.sendAlertEmail(AlertEmailGenerator.java:55)
[stormjar.jar:?]
> 	at org.apache.eagle.alert.engine.publisher.impl.AlertEmailPublisher.onAlert(AlertEmailPublisher.java:130)
[stormjar.jar:?]
> 	at org.apache.eagle.alert.engine.publisher.impl.AlertPublisherImpl.notifyAlert(AlertPublisherImpl.java:88)
[stormjar.jar:?]
> 	at org.apache.eagle.alert.engine.publisher.impl.AlertPublisherImpl.nextEvent(AlertPublisherImpl.java:70)
[stormjar.jar:?]
> 	at org.apache.eagle.alert.engine.runner.AlertPublisherBolt.execute(AlertPublisherBolt.java:92)
[stormjar.jar:?]
> 	at org.apache.storm.daemon.executor$fn__4973$tuple_action_fn__4975.invoke(executor.clj:727)
[storm-core-1.0.3.jar:1.0.3]
> 	at org.apache.storm.daemon.executor$mk_task_receiver$fn__4894.invoke(executor.clj:459)
[storm-core-1.0.3.jar:1.0.3]
> 	at org.apache.storm.disruptor$clojure_handler$reify__4409.onEvent(disruptor.clj:40)
[storm-core-1.0.3.jar:1.0.3]
> 	at org.apache.storm.utils.DisruptorQueue.consumeBatchToCursor(DisruptorQueue.java:453)
[storm-core-1.0.3.jar:1.0.3]
> 	at org.apache.storm.utils.DisruptorQueue.consumeBatchWhenAvailable(DisruptorQueue.java:432)
[storm-core-1.0.3.jar:1.0.3]
> 	at org.apache.storm.disruptor$consume_batch_when_available.invoke(disruptor.clj:73)
[storm-core-1.0.3.jar:1.0.3]
> 	at org.apache.storm.daemon.executor$fn__4973$fn__4986$fn__5039.invoke(executor.clj:846)
[storm-core-1.0.3.jar:1.0.3]
> 	at org.apache.storm.util$async_loop$fn__557.invoke(util.clj:484) [storm-core-1.0.3.jar:1.0.3]
> 	at clojure.lang.AFn.run(AFn.java:22) [clojure-1.7.0.jar:?]
> 	at java.lang.Thread.run(Thread.java:745) [?:1.8.0_102]
> Caused by: java.lang.IncompatibleClassChangeError: Implementing class
> 	at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_102]
> 	at java.lang.ClassLoader.defineClass(ClassLoader.java:763) ~[?:1.8.0_102]
> 	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_102]
> 	at java.net.URLClassLoader.defineClass(URLClassLoader.java:467) ~[?:1.8.0_102]
> 	at java.net.URLClassLoader.access$100(URLClassLoader.java:73) ~[?:1.8.0_102]
> 	at java.net.URLClassLoader$1.run(URLClassLoader.java:368) ~[?:1.8.0_102]
> 	at java.net.URLClassLoader$1.run(URLClassLoader.java:362) ~[?:1.8.0_102]
> 	at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_102]
> 	at java.net.URLClassLoader.findClass(URLClassLoader.java:361) ~[?:1.8.0_102]
> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_102]
> 	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331) ~[?:1.8.0_102]
> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_102]
> 	at org.apache.velocity.runtime.log.Log4JLogChute.initAppender(Log4JLogChute.java:118)
~[stormjar.jar:?]
> 	at org.apache.velocity.runtime.log.Log4JLogChute.init(Log4JLogChute.java:85) ~[stormjar.jar:?]
> 	at org.apache.velocity.runtime.log.LogManager.createLogChute(LogManager.java:157) ~[stormjar.jar:?]
> 	at org.apache.velocity.runtime.log.LogManager.updateLog(LogManager.java:269) ~[stormjar.jar:?]
> 	at org.apache.velocity.runtime.RuntimeInstance.initializeLog(RuntimeInstance.java:871)
~[stormjar.jar:?]
> 	at org.apache.velocity.runtime.RuntimeInstance.init(RuntimeInstance.java:262) ~[stormjar.jar:?]
> 	at org.apache.velocity.app.VelocityEngine.init(VelocityEngine.java:93) ~[stormjar.jar:?]
> 	at org.apache.eagle.alert.engine.publisher.email.EagleMailClient.<init>(EagleMailClient.java:57)
~[stormjar.jar:?]
> 	at org.apache.eagle.alert.engine.publisher.email.AlertEmailSender.run(AlertEmailSender.java:87)
~[stormjar.jar:?]
> 	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:1.8.0_102]
> 	at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:1.8.0_102]
> 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) ~[?:1.8.0_102]
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) ~[?:1.8.0_102]
> 	... 1 more
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message