eagle-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benedict Jin (JIRA)" <j...@apache.org>
Subject [jira] [Created] (EAGLE-983) () => `jsdom 7.x onward only works on Node.js 4
Date Thu, 30 Mar 2017 10:24:41 GMT
Benedict Jin created EAGLE-983:
----------------------------------

             Summary: () => `jsdom 7.x onward only works on Node.js 4
                 Key: EAGLE-983
                 URL: https://issues.apache.org/jira/browse/EAGLE-983
             Project: Eagle
          Issue Type: Bug
          Components: Project Infrastructure
    Affects Versions: v0.4.0
            Reporter: Benedict Jin
             Fix For: Future


=============== Building Web UI ===============
Environment Check...
Environment Check...Pass
npm install...
npm WARN package.json angular-ui-bootstrap@1.3.3 No README data
building...
> ApacheEagleWebApp@ build /home/travis/build/asdf2014/eagle/eagle-server/src/main/webapp/app
> node build/index.js
Generating resource tree...
/home/travis/build/asdf2014/eagle/eagle-server/src/main/webapp/app/node_modules/jsdom/lib/jsdom.js:3
() => `jsdom 7.x onward only works on Node.js 4 or newer: https://github.com/t
 ^
SyntaxError: Unexpected token )
    at Module._compile (module.js:439:25)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at /home/travis/build/asdf2014/eagle/eagle-server/src/main/webapp/app/build/index.js:23:12
    at Object.<anonymous> (/home/travis/build/asdf2014/eagle/eagle-server/src/main/webapp/app/build/index.js:155:3)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message