drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arina Ielchiieva (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DRILL-5680) BasicPhysicalOpUnitTest can't run in Eclipse with Java 8
Date Tue, 13 Mar 2018 11:41:00 GMT

    [ https://issues.apache.org/jira/browse/DRILL-5680?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16396850#comment-16396850
] 

Arina Ielchiieva commented on DRILL-5680:
-----------------------------------------

[~paul-rogers] Drill has officially moved to JDK 8. Do you still see this failure?

> BasicPhysicalOpUnitTest can't run in Eclipse with Java 8
> --------------------------------------------------------
>
>                 Key: DRILL-5680
>                 URL: https://issues.apache.org/jira/browse/DRILL-5680
>             Project: Apache Drill
>          Issue Type: Bug
>    Affects Versions: 1.11.0
>            Reporter: Paul Rogers
>            Priority: Minor
>
> A unit test failure was detected in the test {{BasicPhysicalOpUnitTest}}. Wanted to run
this test in Eclipse to track down the error. But, this test uses Mockito which cannot run
in Java 8 under Eclipse:
> {code}
> java.lang.UnsupportedClassVersionError: org/apache/drill/test/DrillTest : Unsupported
major.minor version 52.0
> 	at java.lang.ClassLoader.defineClass1(Native Method)
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message