drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arina Ielchiieva (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DRILL-6008) Unable to shutdown Drillbit
Date Wed, 06 Dec 2017 16:02:00 GMT

    [ https://issues.apache.org/jira/browse/DRILL-6008?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16280371#comment-16280371
] 

Arina Ielchiieva commented on DRILL-6008:
-----------------------------------------

Yes, host name is defined in /etc/hosts:
{noformat}
XX.XX.XX.XXX	cv1	cv1.lab
{noformat}
Please notice, 
we have {{cv1}} which is short hostname and {{cv1.lab}} which is fqdn. So I assume graceful
shutdown is not working when short hostname is used.
Regarding direct access, I guess you are right, it tried GET but should be POST.

> Unable to shutdown Drillbit
> ---------------------------
>
>                 Key: DRILL-6008
>                 URL: https://issues.apache.org/jira/browse/DRILL-6008
>             Project: Apache Drill
>          Issue Type: Bug
>            Reporter: Arina Ielchiieva
>         Attachments: fqdn.JPG, method_is_not_allowed.JPG, response_of_undefined.JPG
>
>
> Could not shutdown drillbit on cluster where host name was used as drillbit's address
(fqdn.JPG). Pressing shutdown resulted in (response_of_undefined.JPG). I have tried using
ip address and also no luck (method_is_not_allowed.JPG).
> I could shutdown drillbit in embeddded mode but then I saw the following errors (local_shutdown.JPG):
looks like Web UI was trying to get drillbit status though it was down.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message