drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DRILL-5911) Upgrade esri-geometry-api version to 2.0.0 to avoid dependency on org.json library
Date Sat, 28 Oct 2017 15:35:01 GMT

    [ https://issues.apache.org/jira/browse/DRILL-5911?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16223589#comment-16223589
] 

ASF GitHub Bot commented on DRILL-5911:
---------------------------------------

Github user vrozov commented on the issue:

    https://github.com/apache/drill/pull/1012
  
    @vvysotskyi I refer to JSON format that ESRI supports by itself.


> Upgrade esri-geometry-api version to 2.0.0 to avoid dependency on org.json library
> ----------------------------------------------------------------------------------
>
>                 Key: DRILL-5911
>                 URL: https://issues.apache.org/jira/browse/DRILL-5911
>             Project: Apache Drill
>          Issue Type: Task
>    Affects Versions: 1.11.0
>            Reporter: Volodymyr Vysotskyi
>            Assignee: Volodymyr Vysotskyi
>              Labels: ready-to-commit
>             Fix For: 1.12.0
>
>
> Currently, {{drill-gis}} module uses {{esri-geometry-api}} library version 1.2.1. This
version of the library has the dependency on {{org.json}} library:
> {noformat}
> [INFO] org.apache.drill.contrib:drill-gis:jar:1.12.0-SNAPSHOT
> [INFO] \- com.esri.geometry:esri-geometry-api:jar:1.2.1:compile
> [INFO]    \- org.json:json:jar:20090211:compile
> {noformat}
> In {{esri-geometry-api}} v.2.0.0 this dependency on {{org.json}} was removed: https://github.com/Esri/geometry-api-java/commit/9bedde397f2f61675bc687b95875893aa7cd7f2f.

> So we need also update the version of this library to avoid transitive dependency on
{{org.json}} form {{drill-gis}} module.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message