drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arina Ielchiieva (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (DRILL-5698) Drill should start in embedded mode using java 1.8.0_144
Date Wed, 02 Aug 2017 10:08:00 GMT

     [ https://issues.apache.org/jira/browse/DRILL-5698?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Arina Ielchiieva reassigned DRILL-5698:
---------------------------------------

    Assignee: Arina Ielchiieva

> Drill should start in embedded mode using java 1.8.0_144
> --------------------------------------------------------
>
>                 Key: DRILL-5698
>                 URL: https://issues.apache.org/jira/browse/DRILL-5698
>             Project: Apache Drill
>          Issue Type: Bug
>            Reporter: Darren
>            Assignee: Arina Ielchiieva
>
> Currently the start up script
> distribution/src/resources/drill-config.sh
> prevents drill from starting as the regex incorrectly captures the 144 portion of the
version code
> this is because the regex isn't escaped 
> -"$JAVA" -version 2>&1 | grep "version" | egrep -e "1.4|1.5|1.6" > /dev/null
>  +"$JAVA" -version 2>&1 | grep "version" | egrep -e "1\.4|1\.5|1\.6" > /dev/null



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message