drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DRILL-5698) Drill should start in embedded mode using java 1.8.0_144
Date Mon, 07 Aug 2017 20:29:00 GMT

    [ https://issues.apache.org/jira/browse/DRILL-5698?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16117207#comment-16117207
] 

ASF GitHub Bot commented on DRILL-5698:
---------------------------------------

Github user paul-rogers commented on the issue:

    https://github.com/apache/drill/pull/890
  
    Please put the JIRA ticket number in the title so that the system will automagically send
comments & close notices to the JIRA ticket. Example:
    
    DRILL-5698: Escape version number period separator, this captures version numbers


> Drill should start in embedded mode using java 1.8.0_144
> --------------------------------------------------------
>
>                 Key: DRILL-5698
>                 URL: https://issues.apache.org/jira/browse/DRILL-5698
>             Project: Apache Drill
>          Issue Type: Bug
>            Reporter: Darren
>              Labels: ready-to-commit
>             Fix For: 1.12.0
>
>
> Currently the start up script
> distribution/src/resources/drill-config.sh
> prevents drill from starting as the regex incorrectly captures the 144 portion of the
version code
> this is because the regex isn't escaped 
> -"$JAVA" -version 2>&1 | grep "version" | egrep -e "1.4|1.5|1.6" > /dev/null
>  +"$JAVA" -version 2>&1 | grep "version" | egrep -e "1\.4|1\.5|1\.6" > /dev/null



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message