drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Rogers (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DRILL-5509) Upgrade Drill protobuf support from 2.5.0 to latest 3.3
Date Sat, 13 May 2017 02:10:04 GMT
Paul Rogers created DRILL-5509:
----------------------------------

             Summary: Upgrade Drill protobuf support from 2.5.0 to latest 3.3
                 Key: DRILL-5509
                 URL: https://issues.apache.org/jira/browse/DRILL-5509
             Project: Apache Drill
          Issue Type: Improvement
    Affects Versions: 1.10.0
            Reporter: Paul Rogers
            Priority: Minor


Drill uses Google Protobufs for RPC. Drill's Maven compile requires version 2.5.0 from Feb.
2013. The latest version is 3.3. Over time, it may become increasingly hard to find and build
a four-year-old version.

Upgrade Drill to use the latest Protobuf version. This will require updating the Maven protobuf
plugin, and may require other upgrades as well.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message