drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DRILL-5044) After the dynamic registration of multiple jars simultaneously not all UDFs were registered
Date Mon, 28 Nov 2016 18:40:58 GMT

    [ https://issues.apache.org/jira/browse/DRILL-5044?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15702753#comment-15702753

ASF GitHub Bot commented on DRILL-5044:

Github user paul-rogers commented on a diff in the pull request:

    --- Diff: exec/java-exec/src/main/java/org/apache/drill/exec/planner/sql/handlers/DropFunctionHandler.java
    @@ -143,7 +143,7 @@ private Jar unregister(String jarName, RemoteFunctionRegistry remoteFunctionRegi
             if (retryAttempts-- == 0) {
               throw new DrillRuntimeException("Failed to update remote function registry.
Exceeded retry attempts limit.");
    -        unregister(jarName, remoteFunctionRegistry, retryAttempts);
    +        return unregister(jarName, remoteFunctionRegistry, retryAttempts);
    --- End diff --
    Comments from registration process apply here as well.

> After the dynamic registration of multiple jars simultaneously not all UDFs were registered
> -------------------------------------------------------------------------------------------
>                 Key: DRILL-5044
>                 URL: https://issues.apache.org/jira/browse/DRILL-5044
>             Project: Apache Drill
>          Issue Type: Bug
>          Components: Functions - Drill
>    Affects Versions: 1.9.0
>            Reporter: Roman
>            Assignee: Paul Rogers
> I tried to register 21 jars simultaneously (property 'udf.retry-attempts' = 30) and not
all jars were registered. As I see in output, all function were registered and /staging directory
was empty, but not all of jars were moved into /registry directory. 
> For example, after simultaneously registration I saw "The following UDFs in jar test-1.1.jar
have been registered: [test1(VARCHAR-REQUIRED)" message, but this jar was not in /registry
directory. When I tried to run function test1, I got this error: "Error: SYSTEM ERROR: SqlValidatorException:
No match found for function signature test1(<CHARACTER>)". And when I tried to reregister
this jar, I got "Jar with test-1.1.jar name has been already registered".

This message was sent by Atlassian JIRA

View raw message