drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Barclay (Drill) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DRILL-3523) Drill client CLI does not reconnect to Drillbit after long period of inactivity
Date Mon, 24 Aug 2015 17:10:48 GMT

    [ https://issues.apache.org/jira/browse/DRILL-3523?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14709637#comment-14709637
] 

Daniel Barclay (Drill) commented on DRILL-3523:
-----------------------------------------------

Regarding the seeming timeout and disconnection:

I was not able to reproduce that symptom (neither with Drill 1.1 nor with the current state
of 1.2, and neither in embedded mode nor local non-embedded mode).

If you see the behavior again, please check whether there's anything that looks relevant in
the log file (especially when the last visible log activity was, relative to your last user-level
interaction), and check what netstat reports about open TCP listener ports and open TCP connections
(especially ports 8047 and 31010).

> Drill client CLI does not reconnect to Drillbit after long period of inactivity
> -------------------------------------------------------------------------------
>
>                 Key: DRILL-3523
>                 URL: https://issues.apache.org/jira/browse/DRILL-3523
>             Project: Apache Drill
>          Issue Type: Bug
>          Components: Client - CLI
>    Affects Versions: 1.1.0
>            Reporter: Hari Sekhon
>            Assignee: Daniel Barclay (Drill)
>             Fix For: 1.2.0
>
>
> After a period of inactivity in the Drill CLI client before issuing another statement,
it appears to time out the session/connection and the client returns an error instead of reconnecting
to Drill.
> It should instead just implicitly "!reconnect" itself since I can't think of a good reason
why I have to do this by hand every time.
> Unlike in DRILL-3514 the drillbit in this case was never restarted, although the same
fix could probably solve both issues.
> The error received when trying to issue a new query after some absence is:
> {code}Error: CONNECTION ERROR: Connection /x.x.x.x:54367 <--> /x.x.x.x:31010 (user
client) closed unexpectedly.
> [Error Id: 68714cc2-65f5-4cac-b062-44331f8f4c31 ] (state=,code=0)
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message