drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacques Nadeau (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DRILL-3340) Add metric name to MetricValue
Date Tue, 23 Jun 2015 21:36:43 GMT

    [ https://issues.apache.org/jira/browse/DRILL-3340?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14598418#comment-14598418
] 

Jacques Nadeau commented on DRILL-3340:
---------------------------------------

We normalized this for compactness.  I'm initially -1 on adding it repeatedly.  Can you do
a quick analysis of a the impact this has on a large profile?  Are you only focused on named
metrics or are you also focused on operator ids?

> Add metric name to MetricValue
> ------------------------------
>
>                 Key: DRILL-3340
>                 URL: https://issues.apache.org/jira/browse/DRILL-3340
>             Project: Apache Drill
>          Issue Type: Improvement
>            Reporter: Sudheesh Katkam
>            Assignee: Sudheesh Katkam
>            Priority: Minor
>             Fix For: 1.2.0
>
>         Attachments: DRILL-3340.1.patch.txt
>
>
> + Useful when reading JSON query profile.
> + Rename FragmentStats#getOperatorStats to FragmentStats#newOperatorStats



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message