drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Barclay (Drill) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DRILL-3285) Split DrillCursor.next(), clean up DrillCursor for clarity
Date Thu, 18 Jun 2015 06:27:00 GMT

     [ https://issues.apache.org/jira/browse/DRILL-3285?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Barclay (Drill) updated DRILL-3285:
------------------------------------------
    Attachment: DRILL-3285.Pt5.3.patch.txt
                DRILL-3285.AllPts.3.patch.txt

> Split DrillCursor.next(), clean up DrillCursor for clarity
> ----------------------------------------------------------
>
>                 Key: DRILL-3285
>                 URL: https://issues.apache.org/jira/browse/DRILL-3285
>             Project: Apache Drill
>          Issue Type: Bug
>          Components: Client - JDBC
>            Reporter: Daniel Barclay (Drill)
>            Assignee: Deneche A. Hakim
>             Fix For: 1.1.0
>
>         Attachments: DRILL-3285.AllPts.1.patch.txt, DRILL-3285.AllPts.2.patch.txt, DRILL-3285.AllPts.3.patch.txt,
DRILL-3285.Pt1.1.patch.txt, DRILL-3285.Pt2.1.patch.txt, DRILL-3285.Pt3.1.patch.txt, DRILL-3285.Pt4.1.patch.txt,
DRILL-3285.Pt5.1.patch.txt, DRILL-3285.Pt5.2.patch.txt, DRILL-3285.Pt5.3.patch.txt
>
>
> Clean up the mess in DrillCursor, namely the poorly named (and of course undocumented)
flow-control flags and the flag-laden next() method.
> ==========
> DRILL-3285: Part 1--Prep., Hygiene:  Mainly, adding comments.
> Added/edited comments:
> - field doc. comments
> - method doc. comments
> - branch/block comments
> Removed unused recordBatchCount and getRecordBatchCount().
> Added logger call for spurious batch.
> Various cleanup:
> - Cleaned up logger.
> - Added "final" on updateColumns().
> - Wrapped some lines
> - Misc. comment whitespace.
> ==========
> DRILL-3285: Part 2--Renaming.
> Renamed state/control-flow members:
> - started -> initialSchemaLoaded
> - first -> beforeFirstBatch
> - redoFirstNext -> returnTrueForNextCallToNext
> - finished -> afterLastRow
> Renamed other items:
> - changed -> schemaChanged
> - currentBatch -> currentBatchHolder
> - DrillResultSet's currentBatch -> batchLoader
> ==========
> DRILL-3285: Part 3--Invert beforeFirstBatch -> ! afterFirstBatch.
> ==========
> DRILL-3285: Part 4--Reorder fields, updateColumns.
> ==========
> DRILL-3285: Part 5--Split old hacky next() into separate methods.
> Split the original public next() method (which was hacked to handle an extra,
> initial call to read the schema batch) into:
> - new loadInitialSchema() (for handling the call for the schema)
> - modified next() (for handling normal calls from ResultSet.next())
> - new private nextRowInternally() (for common code)
> Pulls invariant afterFirstBatch up out of bogus-batch loop.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message