drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Toole (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DRILL-2614) "SHOW SCHEMAS" should be "SHOW SCHEMATA"
Date Wed, 01 Apr 2015 18:02:52 GMT

    [ https://issues.apache.org/jira/browse/DRILL-2614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14391101#comment-14391101
] 

Patrick Toole commented on DRILL-2614:
--------------------------------------

It is my understanding that ANSI SQL does not get involved in Meta Data management. However,
INFORMATION_SCHEMA uses "SCHEMATA". Most databases have a naming convention different; ie
SCHEMA / DATABASE / INSTANCE is ambiguous and different between vendors.


> "SHOW SCHEMAS" should be "SHOW SCHEMATA"
> ----------------------------------------
>
>                 Key: DRILL-2614
>                 URL: https://issues.apache.org/jira/browse/DRILL-2614
>             Project: Apache Drill
>          Issue Type: Improvement
>          Components: Metadata
>    Affects Versions: 0.7.0
>            Reporter: Patrick Toole
>            Assignee: Steven Phillips
>            Priority: Minor
>             Fix For: 1.0.0
>
>
> The plural of "schema" is "schemata". 
> At a minimum, both should work.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message