drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Hsuan-Yi Chu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DRILL-1921) Throw unsupported error message some set operators that are not currently supported
Date Sat, 07 Feb 2015 01:06:35 GMT

     [ https://issues.apache.org/jira/browse/DRILL-1921?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sean Hsuan-Yi Chu updated DRILL-1921:
-------------------------------------
    Attachment:     (was: DRILL-1921.3.patch)

> Throw unsupported error message some set operators that are not currently supported
> -----------------------------------------------------------------------------------
>
>                 Key: DRILL-1921
>                 URL: https://issues.apache.org/jira/browse/DRILL-1921
>             Project: Apache Drill
>          Issue Type: Bug
>          Components: SQL Parser
>            Reporter: Victoria Markman
>            Assignee: Jinfeng Ni
>             Fix For: 0.8.0
>
>         Attachments: DRILL-1921.7.patch, DRILL-1921.8.patch
>
>
> Throw unsupported error message for these operators: (instead of "Could not be implemented
error below")
> INTERSECT
> EXCEPT
> UNION
> CROSS JOIN
> FULL OUTER JOIN
> Query failed: Query failed: Unexpected exception during fragment initialization: Node
[rel#517133:Subset#3.LOGICAL.ANY([]).[]] could not be implemented; planner state:
> Enhacement requests in Jira for these above mentioned operators:
> {code}
> INTERSECT       DRILL-1308
> MINUS                No enhancement request ( not recognized in grammar)
> EXCEPT             No enhancement request
> UNION                DRILL-1169
> CROSS JOIN     DRILL-786
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message