drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Barclay (Drill/MapR) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DRILL-2064) Internal "Float4" and "Float8" names are confusing; rename using "Float" and "Double"
Date Fri, 23 Jan 2015 22:24:35 GMT

    [ https://issues.apache.org/jira/browse/DRILL-2064?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14290122#comment-14290122
] 

Daniel Barclay (Drill/MapR) commented on DRILL-2064:
----------------------------------------------------

Note:  Per Wikipedia:

IEEE 754 does not use "float" and "double."

IEEE 754-1985 used the names "single" and "double."
IEEE 754-2008 defines "binary32" and "binary64" (among others). 

(Or course, those names don't include any indicate that they're floating-point (vs. integral)
because IEEE 754 deals with only floating-point representations.





> Internal "Float4" and "Float8" names are confusing; rename using "Float" and "Double"
> -------------------------------------------------------------------------------------
>
>                 Key: DRILL-2064
>                 URL: https://issues.apache.org/jira/browse/DRILL-2064
>             Project: Apache Drill
>          Issue Type: Bug
>            Reporter: Daniel Barclay (Drill/MapR)
>
> [For/from Jacques:]
> The internal names (e.g., enumerations,  vector subtypes, function names) containing
"Float4" and "Float8" are confusing since they don't correspond to type names "float" and
"double" in Java, etc.
> Things currently named using "Float4" should be renamed to names using "Float"; things
currently named using "Float8" should be renamed using "Double".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message