drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Victoria Markman (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DRILL-1921) Throw unsupported error message some set operators that are not currently supported
Date Fri, 02 Jan 2015 22:32:34 GMT
Victoria Markman created DRILL-1921:
---------------------------------------

             Summary: Throw unsupported error message some set operators that are not currently
supported
                 Key: DRILL-1921
                 URL: https://issues.apache.org/jira/browse/DRILL-1921
             Project: Apache Drill
          Issue Type: Bug
          Components: SQL Parser
            Reporter: Victoria Markman
             Fix For: 0.8.0


Throw unsupported error message for these operators: (instead of "Could not be implemented
error below")

INTERSECT
EXCEPT
UNION
CROSS JOIN
FULL OUTER JOIN

Query failed: Query failed: Unexpected exception during fragment initialization: Node [rel#517133:Subset#3.LOGICAL.ANY([]).[]]
could not be implemented; planner state:

Enhacement requests in Jira for these above mentioned operators:

{code}
INTERSECT       DRILL-1308
MINUS                No enhancement request ( not recognized in grammar)
EXCEPT             No enhancement request
UNION                DRILL-1169
CROSS JOIN     DRILL-786
{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message