drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Varadharajan (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (DRILL-1819) Relax maven-enforcer-plugin to allow latest builds of java 1.8.0
Date Sun, 07 Dec 2014 07:02:13 GMT

     [ https://issues.apache.org/jira/browse/DRILL-1819?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Varadharajan resolved DRILL-1819.
---------------------------------
    Resolution: Invalid

As of now Java 8 is not supported

> Relax maven-enforcer-plugin to allow latest builds of java 1.8.0
> ----------------------------------------------------------------
>
>                 Key: DRILL-1819
>                 URL: https://issues.apache.org/jira/browse/DRILL-1819
>             Project: Apache Drill
>          Issue Type: Improvement
>          Components: Tools, Build & Test
>            Reporter: Varadharajan
>              Labels: build, newbie
>   Original Estimate: 0.5h
>  Remaining Estimate: 0.5h
>
> Currently maven-enforcer-plugin is configured to restrict the java versions to 1.7 and
1.8. Unfortunately this does not allow to make use of the latest builds of java 1.8.0. For
example, we won't be able to build drill on java version "1.8.0_25". While having the plugin
gives us a lot of advantage in terms of ensuring we have the right platform setup before,
we build the code on the machine; not including the latest builds of java for the already
enabled java version 1.8, makes it too restrictive. This task is to relax it a bit to include
all builds for java 1.8.0



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message