drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hanifi Gunes (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DRILL-1594) SQL exception when querying JSON
Date Sat, 08 Nov 2014 00:26:33 GMT

    [ https://issues.apache.org/jira/browse/DRILL-1594?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14203010#comment-14203010
] 

Hanifi Gunes commented on DRILL-1594:
-------------------------------------

[~Neeraja] correct me if I am wrong. The dataset in the query had a field that was not homogenous,
which in turn was causing this problem. So I am linking this issue with DRILL-1602 and marking
as resolved.

> SQL exception when querying JSON
> --------------------------------
>
>                 Key: DRILL-1594
>                 URL: https://issues.apache.org/jira/browse/DRILL-1594
>             Project: Apache Drill
>          Issue Type: Bug
>            Reporter: Neeraja
>            Assignee: Hanifi Gunes
>
> I can reproduce this with many queries, but narrowing down, it may actually have to do
with the number of rows that are being retrieved or a specific record.
> I tried a query as follows (i.e limit 10034). It returns 10033 rows and then fails with
an exception. A modified limit 10033 does succeed.
>  select * from dfs.`/users/nrentachintala/Downloads/yelp_dataset_challenge_academic_dataset/yelp_academic_dataset_business.json`
b  limit 10034;
> -------------------
> java.lang.RuntimeException: java.sql.SQLException: Failure while trying to get next result
batch.
> 	at sqlline.SqlLine$IncrementalRows.hasNext(SqlLine.java:2514)
> 	at sqlline.SqlLine$TableOutputFormat.print(SqlLine.java:2148)
> 	at sqlline.SqlLine.print(SqlLine.java:1809)
> 	at sqlline.SqlLine$Commands.execute(SqlLine.java:3766)
> 	at sqlline.SqlLine$Commands.sql(SqlLine.java:3663)
> 	at sqlline.SqlLine.dispatch(SqlLine.java:889)
> 	at sqlline.SqlLine.begin(SqlLine.java:763)
> 	at sqlline.SqlLine.start(SqlLine.java:498)
> 	at sqlline.SqlLine.main(SqlLine.java:460)
> I enabled text mode using alter system set `store.json.all_text_mode`=true;
> The same error occurs with this configuration as well.
> Here is another example where it fails.
> select * from dfs.`/users/nrentachintala/Downloads/yelp_dataset_challenge_academic_dataset/yelp_academic_dataset_business.json`
b where review_count > 1000;



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message