drill-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aditya Kishore (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DRILL-1490) Upgrade to ProGaurd 5.0
Date Fri, 03 Oct 2014 22:44:35 GMT

     [ https://issues.apache.org/jira/browse/DRILL-1490?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Aditya Kishore updated DRILL-1490:
----------------------------------
    Attachment: DRILL-1490-Upgrade-to-ProGaurd-5.0.patch

Attaching patch, however need to run more tests before this can be committed.

> Upgrade to ProGaurd 5.0
> -----------------------
>
>                 Key: DRILL-1490
>                 URL: https://issues.apache.org/jira/browse/DRILL-1490
>             Project: Apache Drill
>          Issue Type: Sub-task
>          Components: Tools, Build & Test
>    Affects Versions: 0.6.0
>            Reporter: Aditya Kishore
>            Assignee: Aditya Kishore
>         Attachments: DRILL-1490-Upgrade-to-ProGaurd-5.0.patch
>
>
> Building Drill with JDK 8 fails at {{jdbc-all}} module with ProGaurd throwing the following
error.
> {noformat}
> (Unsupported class version number [52.0] (maximum 51.0, Java 1.7)))
> {noformat}
> Looks like we need to upgrade to [ProGaurd version 5.0|http://proguard.sourceforge.net/downloads.html]
to support Java 8.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message