drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From arina-ielchiieva <...@git.apache.org>
Subject [GitHub] drill pull request #877: DRILL-5660: Drill 1.10 queries fail due to Parquet ...
Date Fri, 28 Jul 2017 11:23:50 GMT
Github user arina-ielchiieva commented on a diff in the pull request:

    https://github.com/apache/drill/pull/877#discussion_r130067083
  
    --- Diff: exec/java-exec/src/test/java/org/apache/drill/exec/store/parquet/TestParquetMetadataCache.java
---
    @@ -495,14 +495,14 @@ public void testFutureUnsupportedMetadataVersion() throws Exception
{
         try {
           test("use dfs_test.tmp");
           test("create table `%s` as select * from cp.`tpch/nation.parquet`", unsupportedMetadataVersion);
    -      String lastVersion = Iterables.getLast(MetadataVersion.Constants.SUPPORTED_VERSIONS);
    -      for (String supportedVersion : MetadataVersion.Constants.SUPPORTED_VERSIONS) {
    -        if (new MetadataVersion(lastVersion).compareTo(new MetadataVersion(supportedVersion))
< 0) {
    +      MetadataVersion lastVersion = Iterables.getLast(MetadataVersion.Constants.SUPPORTED_VERSIONS);
    --- End diff --
    
    No need to this manually:
    ```
    List<MetadataVersion> supportedVersions = new ArrayList(MetadataVersion.Constants.SUPPORTED_VERSIONS);
    Collections.sort(supportedVersions);
    MetadataVersion lastVersion = supportedVersions.get(supportedVersions.size() - 1);
    ```


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message