drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jinfengni <...@git.apache.org>
Subject [GitHub] drill pull request #704: DRILL-5125: Provide option to use generic code for ...
Date Thu, 30 Mar 2017 23:12:44 GMT
Github user jinfengni commented on a diff in the pull request:

    --- Diff: exec/vector/src/main/codegen/templates/NullableValueVectors.java ---
    @@ -374,6 +374,19 @@ public void copyFromSafe(int fromIndex, int thisIndex, Nullable${minor.class}Vec
         values.copyFromSafe(fromIndex, thisIndex, from.values);
    +  @Override
    +  public void copyEntry(int toIndex, ValueVector from, int fromIndex) {
    +    Nullable${minor.class}Vector fromVector = (Nullable${minor.class}Vector) from;
    +    <#if type.major == "VarLen">
    +    // This method is to be called only for loading the vector
    --- End diff --
    Will it make sense to put this comment as part of java doc for this copyEntry() method,
so that people knows this method should be called sequentially ? 

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.

View raw message