drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gopal Nagar (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DRILL-4959) Drill 8.1 not able to connect to S3
Date Mon, 24 Oct 2016 17:11:59 GMT
Gopal Nagar created DRILL-4959:

             Summary: Drill 8.1 not able to connect to S3
                 Key: DRILL-4959
                 URL: https://issues.apache.org/jira/browse/DRILL-4959
             Project: Apache Drill
          Issue Type: Bug
    Affects Versions: 1.8.0
            Reporter: Gopal Nagar

Hi Team,

I have followed below details to integrate Drill with AWS S3. Query keep running for hours
and doesn't display any output (I am querying only 2 row file from S3).

Reference link

Query Format (Tried from UI & CLI)
select * from `s3`.`hive.csv` LIMIT 10;
select * from `s3`.`bucket_name/hive.csv` LIMIT 10;

After seeing below log, I tried including jets3t-0.9.3.jar in jars directory but it doesn't
fix my problem.

Log Details
2016-10-24 17:00:02,461 [27f1c1ec-d82e-ba2a-2840-e7104320418f:foreman] INFO  o.a.drill.exec.work.foreman.Foreman
- Query text for query id 27f1c1ec-d82e-ba2a-2840-e7104320418f: select * from `s3`.`hive.csv`
2016-10-24 17:00:02,479 [drill-executor-39] ERROR o.a.d.exec.server.BootStrapContext - org.apache.drill.exec.work.foreman.Foreman.run()
leaked an exception.
java.lang.NoClassDefFoundError: org/jets3t/service/S3ServiceException

This message was sent by Atlassian JIRA

View raw message