drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xadi Del (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DRILL-3977) unable to configure postgreSQL JDBC driver using apache drill 1.2
Date Mon, 26 Oct 2015 14:46:27 GMT
Xadi Del created DRILL-3977:
-------------------------------

             Summary: unable to configure postgreSQL JDBC driver using apache drill 1.2
                 Key: DRILL-3977
                 URL: https://issues.apache.org/jira/browse/DRILL-3977
             Project: Apache Drill
          Issue Type: Bug
          Components: Client - JDBC
            Reporter: Xadi Del


Hello,

I'd like to use the new RDBMS capability working with apache drill 1.2.0.
I followed this: https://drill.apache.org/docs/jdbc-storage-plugin/ 

I put the mysql drivier jar file in this folder 'apache-drill-1.2.0\jars\3rdparty'

And now, I'm trying to create a storage configuration. I am doing it using the web console
(http://127.0.0.1:8047). When I try to add:

{
  "type": "jdbc",
  "driver": "com.mysql.jdbc.Driver",
  "url": "jdbc:mysql://localhost:3306",
  "username": "root",
  "password": "mypassword",
  "enabled": true
}  

It is showing error: error(Unable to create / update storage)

Even with just the following it's not working (same error):

{
  "type": "jdbc"
}

To link apache drill classpath and the jar I added drill.exec.sys.store.provider.local.path
= "mysql-connector-java-5.1.37-bin.jar"

to the drill-override.conf -> result is:

drill.exec: {
  cluster-id: "drillbits1",
  zk.connect: "localhost:2181",
  drill.exec.sys.store.provider.local.path = "mysql-connector-java-5.1.37-bin.jar"
}

Any idea? Thanks, 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message