drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Hsuan-Yi Chu (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DRILL-3400) After shifting CTAS's data, query on CTAS table failed
Date Fri, 26 Jun 2015 19:15:04 GMT
Sean Hsuan-Yi Chu created DRILL-3400:

             Summary: After shifting CTAS's data, query on CTAS table failed 
                 Key: DRILL-3400
                 URL: https://issues.apache.org/jira/browse/DRILL-3400
             Project: Apache Drill
          Issue Type: Bug
          Components: Query Planning & Optimization
            Reporter: Sean Hsuan-Yi Chu
            Assignee: Jinfeng Ni

A simple query like this:
create table `ttt` partition by (r_regionkey) as select * from cp.`tpch/region.parquet`;

Without touching generated data from CTAS, this query select * from `ttt`; works. 

Then, I tried to reorganize the parquet generated by CTAS as:
|-----Q1/ ... .pq
       Q2/ ... .pq
       Q3/ ... .pq

However, after this manual moving, any query fails. Surprisingly, even after I manually move
the data to the original place, the queries which worked before all failed with:

Error: PARSE ERROR: From line 1, column 15 to line 1, column 19: Table 'ttt' not found

This message was sent by Atlassian JIRA

View raw message