distributedlog-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arvind Kandhare (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DL-193) Use the latest version of Guava
Date Wed, 15 Mar 2017 21:22:41 GMT

    [ https://issues.apache.org/jira/browse/DL-193?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15927009#comment-15927009
] 

Arvind Kandhare commented on DL-193:
------------------------------------

@sijie bookkeeper code actually uses Guava APIs (timer and stopwatch etc). The PR on that
side ensure that the latest APIs are used. The dependency here (in DL) is because of the LocalBookie
implementation. Otherwise I did not see any instance where DL actually uses it. So it can
not be removed from BK. 

> Use the latest version of Guava
> -------------------------------
>
>                 Key: DL-193
>                 URL: https://issues.apache.org/jira/browse/DL-193
>             Project: DistributedLog
>          Issue Type: Improvement
>          Components: builds, distributedlog-core, distributedlog-service
>            Reporter: Arvind Kandhare
>            Assignee: Arvind Kandhare
>
> The Guava version used is 16.0 which is too old. It should be 20.0.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message